Not Booting Linux On A HP Proliant Microserver Gen8

After some days trying to install several different Linux distributions I always got a missing file as answer from Grub when I tried to boot into the fresh installed system. I tried so many different things but nothing worked. I remembered that the Microserver could have some problems with large partitions. I installed a 8TB HDD and tried to use only one large partition for root and the installation never worked. It was also often mentioned that a boot flag must be setted but still nothing worked.

The solution for me was simple: Decrease the root partition to a small value or use a separate boot partition. I used a 200 GB root partition and a separate home partition with the rest of the space and everything worked with Debian.

URL rewrite in .htaccess is not working. Check your server configuration. friendica

Folgenden Fehler hatte ich bei der Installation von Friendica auf Ubuntu Server: URL rewrite in .htaccess is not working. Check your server configuration. friendica.

Der Fehler ließ sich bei mir recht einfach lösen, da die .htaccess nicht funktionierte.

Im Verzeichnis /etc/apache/apache2.conf editieren und dort folgenden Eintrag zufügen oder abändern:

<Directory /var/www/html >

AllowOverride ALL

</Directoy>

Apache2 neu starten und alles geht.

Alternativer Server

Ich hatte in den letzten Jahren recht viel mit zwei Banana PIs im Heimnetzwerk experimentiert und mir damit etwas Linux-Kenntnisse angeeignet. In der Zeit habe ich schon immer mal was nach einem leistungsfähigeren Ersatz gesucht, war aber nie so recht zufrieden. Vor einigen Wochen hatte sich das vorerst ideale Upgrade in Form meines alten Thinkpad X201 gefunden. Der Thinkpad hat Gigabitnettzwerk, wodurch mit USB-Platten natürlich über SMB ein NAS möglich ist. Leider hat der kein USB 3.0. Ich hab etwas recherchiert und mir eine Expresscard mit USB 3.0 besorgt. Tatsächlich schafft der X201 damit einen Durchsatz von 80 MB/s über die Expresscard und damit wesentlich mehr als die vorher ca. 20-25 MB/s. Real schafft das Ding im Netzwerk aber seltsamerweise ca. 50 MB/s und manchmal auch nur mit einem Limit von 10 MB/s. Das liegt aber vielleicht derzeit an meinem neuen Mint 18 KDE auf einem anderen Rechner. Der X201 hat auch einen recht schnellen I5 und 4GB RAM, wodurch recht viele Programme/Dienste möglich sind, die auf den Bananen schon in die Grenze gingen. Continue reading “Alternativer Server”

Globaler Proxy für Linux Mint

Der globale Proxy für Linux Mint muss folgendermaßen festgelegt werden:

sudo nano /etc/environment

Dort folgende Einträge zufügen oder abändern:

http_proxy=http://Proxy:Port/
https_proxy=http://Proxy:Port/
ftp_proxy=http://Proxy:Port/
no_proxy=”localhost,127.0.0.1,localaddress,.localdomain.com”
HTTP_PROXY=http://Proxy:Port/
HTTPS_PROXY=http://Proxy:Port/
FTP_PROXY=http://Proxy:Port/
NO_PROXY=”localhost,127.0.0.1,localaddress,.localdomain.com”

Dann noch folgende Datei editieren:

sudo nano /etc/apt/apt.conf.d/S95proxies 

Und folgende Einträge zufügen oder abändern:

Acquire::http::proxy "http://Proxy:Port/";
Acquire::https::proxy "http://Proxy:Port/";
Acquire::ftp::proxy "http://Proxy:Port/";

Grafikprobleme mit Linux Mint bei aelteren Nvidia Grafikkarten zB onboard

Linux Mint 17 wollte auf meinem Optiplex 740 nicht funktionieren und frierte im Betrieb kurz nach dem einloggen ein (freeze).

Nach drei Tagen rumprobieren hier die einfache Loesung durch Verwendung der aktuellen nvidia treiber:

http://www.upubuntu.com/2012/09/how-to-install-nvidia-drivers-using.html

– Mint im Kompatibilitaetsmodus installieren

– Im Recoverymodus hochfahren und auf die shell wechseln

– apt-get update

– apt-get upgrade (dauert!)

sudo apt-get install nvidia-current nvidia-settings

Erfahrungsbericht 1und1 Tarifumstellung

Diese Woche hatte ich meinen 6000er Vertrag bei 1und1 auf DSL 16000 umstellen lassen. An meinem Ort ist das derzeit das höchste was möglich ist. leider nichts mit VDSL. Im 6000er Vertrag gibts 500 kbit Upload, was derzeit durch meine ganzen Dienste wirklich nicht toll ist. Der 16000er hat 1Mbit. So dachte ich zumindest.

Nach nur zwei Tagen habe ich eine Bestätigung bekommen, dass meine Umstellung beendet wurde. Also mal in die Fritzbox geschaut was die Daten sagen. Ich hatte nun eine Leitung mit 12 Mbit Down und 520 kbit Up. Also hatte sich nicht wirklich was getan und im Upload gar nichts. Ein !und1 Techniker bestätigte dann auch, dass nicht wirklich mehr drin ist, da die Leitung das nicht hergibt. Das war nun wirklich ein dreistes Stück von 1und1, da die meisten Menschen das gar nicht mitbekommen würden. Ausserdem wurde mir gesagt, das die Werte schwanken können. Das war jetzt auch ziemlich dreist, weil ich für eine garantierte Leistung bezahle und nicht wie es grade kommt. Ausserdem hatte sich im Upload rein gar nichts getan.

Nun wollte ich meinen alten Vertrag zurück haben und wurde ca. 6 mal weitervermittelt und niemand fühlte sich dafür verantwortlich. Ich werde diese Umstellung jetzt schriftlich stornieren müssen und kann damit 1und1 gar nicht mehr empfehlen.

Momentan hab ich übrigens 7000 Down und 524 Up. Tolle Umstellung!

500 kbit Upload in einer großen Stadt in DE. Das ist echt lächerlich.